Добавил:
Опубликованный материал нарушает ваши авторские права? Сообщите нам.
Вуз: Предмет: Файл:
Cisco CCIP MPLS Study Guide - James Reagan.pdf
Скачиваний:
250
Добавлен:
24.05.2014
Размер:
6.47 Mб
Скачать

When reviewing Cisco’s exam objectives in preparation for the exam, the “and any other relevant topics” line might get you worrying.

This chapter tries to address those topics. Although there are no specific exam objectives covered in this chapter, the topics discussed here may show up on the MPLS exam.

So far, you’ve learned a lot about MPLS and MPLS VPNs. This chapter explains the steps required to set up MPLS VPNs using static routes and E-BGP to communicate with CE routers.

In addition, you’ve learned all about simple MPLS VPN topologies. This chapter introduces you to more complex MPLS VPN topologies.

Static Routing

Although the exam objectives do not require you to know about static routes, I’d like you to see a working example of how static routes can be used in a simple MPLS VPN.

Figure 8.1 illustrates the simple network we’ll use in this example.

F I G U R E 8 . 1 A simple service provider network

IGP

 

Serial

0/0

0/0

Serial

0/1

0/0

0/1

0/0

 

Serial 0/1

Serial

 

Serial

 

Serial Serial

 

Serial 0/1

 

 

 

 

 

 

 

 

PE1

 

P1

 

 

P2

 

PE2

Serial 0

 

 

 

 

 

 

 

Serial 0

CE1

 

 

 

 

 

 

 

CE2

I-BGP

Copyright ©2002 SYBEX, Inc., Alameda, CA

www.sybex.com

Static Routing 319

Figure 8.2 illustrates the routing protocol utilization of the network in Figure 8.1.

F I G U R E 8 . 2 Routing protocol utilization

RIPv2

Peer 1

Atlanta

Core

Raleigh

Peer 2

I-BGP

AS 65000

Table 8.1 lists the IP addresses and interfaces of the CE devices in

Figure 8.1.

T A B L E 8 . 1 Customer Addressing

Device

Loopback 0

Serial 0

 

 

 

Peer 1

192.168.1.1/32

192.168.3.5/30

Peer 2

192.168.2.1/32

192.168.3.10/30

 

 

 

Table 8.2 lists the IP addresses and interfaces of the service provider devices in Figure 8.1.

T A B L E 8 . 2

Service Provider Addressing

 

 

 

 

 

 

 

 

 

Device

Loopback 0

Serial 0/0

Serial 0/1

Serial 0/3

 

 

 

 

 

 

 

Atlanta

204.134.83.1/32

204.134.83.5/30

192.168.3.6/30

N/A

 

Core

204.134.83.2/32

204.134.83.9/30

204.134.83.6/30

N/A

 

Raleigh

204.134.83.3/32

N/A

192.168.3.9/30

204.134.83.10/30

 

 

 

 

 

 

Copyright ©2002 SYBEX, Inc., Alameda, CA

www.sybex.com

320 Chapter 8 Advanced MPLS Topics

Device Configuration

Presently, the network is set up with an IGP (RIPv2), tag switching, and MP-BGP between the Atlanta and Raleigh POP routers, as you can see in the running-config of the Raleigh POP router:

Raleigh#show running-config

Building configuration...

Current configuration : 1997 bytes

!

version 12.1

service timestamps debug uptime service timestamps log uptime no service password-encryption

!

hostname Raleigh

!

enable password cisco

!

!

!

!

!

memory-size iomem 25 ip subnet-zero

ip tcp synwait-time 5 no ip domain-lookup

!

!

ip cef

cns event-service server

!

!

!

!

!

Copyright ©2002 SYBEX, Inc., Alameda, CA

www.sybex.com

Static Routing 321

interface Loopback0

ip address 204.134.83.3 255.255.255.255

!

interface Serial0/0 no ip address shutdown

no fair-queue clockrate 64000

!

interface Serial0/1

description *** Link to Peer2 ***

ip address 192.168.3.9 255.255.255.252 clockrate 64000

!

interface Serial0/2 no ip address shutdown

clockrate 64000

!

interface Serial0/3

description *** Link to Core Router ***

ip address 204.134.83.10 255.255.255.252 tag-switching ip

clockrate 64000

!

interface Ethernet1/0 no ip address shutdown

!

interface Ethernet1/1 no ip address shutdown

!

interface Ethernet1/2 no ip address shutdown

!

Copyright ©2002 SYBEX, Inc., Alameda, CA

www.sybex.com

322 Chapter 8 Advanced MPLS Topics

interface Ethernet1/3 no ip address shutdown

!

router rip version 2

network 204.134.83.0

!

router bgp 65000

no synchronization

bgp log-neighbor-changes

neighbor 204.134.83.1 remote-as 65000 neighbor 204.134.83.1 update-source Loopback0 neighbor 204.134.83.1 next-hop-self

no auto-summary

!

!

address-family vpnv4

neighbor 204.134.83.1 activate

neighbor 204.134.83.1 send-community both no auto-summary

exit-address-family

!

ip classless

no ip http server

!

!

!

line con 0 exec-timeout 0 0 privilege level 15 logging synchronous transport input none

ip netmask-format decimal line aux 0

line vty 0 4

Copyright ©2002 SYBEX, Inc., Alameda, CA

www.sybex.com

Static Routing 323

privilege level 15 password cisco logging synchronous login

ip netmask-format decimal

!

end

Notice in the running-config of the Atlanta POP router that RIPv2, tag switching, and MP-BGP are configured:

Atlanta#show running-config

Building configuration...

Current configuration : 1972 bytes

!

version 12.1

service timestamps debug uptime service timestamps log uptime no service password-encryption

!

hostname Atlanta

!

enable password cisco

!

!

!

!

!

memory-size iomem 25 ip subnet-zero

ip tcp synwait-time 5 no ip domain-lookup

!

!

ip cef

cns event-service server

!

!

Copyright ©2002 SYBEX, Inc., Alameda, CA

www.sybex.com

324 Chapter 8 Advanced MPLS Topics

!

!

!

interface Loopback0

ip address 204.134.83.1 255.255.255.255

!

interface Serial0/0

description *** Link to Core Router ***

ip address 204.134.83.5 255.255.255.252 tag-switching ip

no fair-queue clockrate 64000

!

interface Serial0/1

description *** Link to Peer1 ***

ip address 192.168.3.6 255.255.255.252 clockrate 64000

!

interface Serial0/2 no ip address shutdown

clockrate 64000

!

interface Serial0/3 no ip address shutdown

clockrate 64000

!

interface Ethernet1/0 no ip address shutdown

!

interface Ethernet1/1 no ip address shutdown

!

Copyright ©2002 SYBEX, Inc., Alameda, CA

www.sybex.com

Static Routing 325

interface Ethernet1/2 no ip address shutdown

!

interface Ethernet1/3 no ip address shutdown

!

router rip version 2

network 204.134.83.0

!

router bgp 65000

no synchronization

bgp log-neighbor-changes

neighbor 204.134.83.3 remote-as 65000 neighbor 204.134.83.3 update-source Loopback0 neighbor 204.134.83.3 next-hop-self

no auto-summary

!

address-family vpnv4

neighbor 204.134.83.3 activate

neighbor 204.134.83.3 send-community both no auto-summary

exit-address-family

!

ip classless

no ip http server

!

!

!

line con 0 exec-timeout 0 0 privilege level 15 logging synchronous transport input none

Copyright ©2002 SYBEX, Inc., Alameda, CA

www.sybex.com