Добавил:
Upload Опубликованный материал нарушает ваши авторские права? Сообщите нам.
Вуз: Предмет: Файл:
Прикладное_ПО_ПК.doc
Скачиваний:
12
Добавлен:
01.12.2018
Размер:
4.05 Mб
Скачать
      1. Данные в ячейках электронной таблицы

В любую ячейку электронной таблицы можно записать:

– символьные данные;

– числовые данные;

– формулу.

Символьные данные – последовательность символов, не являющаяся ни числом, ни формулой.

Числовые данные – это последовательность цифр с раз­делителем целой и дробной части, с учетом знака числа. Формат отображения числа может быть следующим: числовой (179; -341.8; +1128.945); денежный (1 235,50р.); финансовый ($1 235,50; 523,50р.); дата (25.03.2006; 25 мар 06); время (11:23:00; 11:23); дробный (1 3/20); процентный (98%) и экспоненциальный(1,24E+04). Разделитель целой и дробной части – точка или запятая (MS Excel). В случае, если число не может поместиться в ячейку полностью, то вместо него появляются символы ###########. Это значит, что необходимо увеличить ширину столбца.

Формула – выражение, предназначенное для производства вычислений и состоящее из операндов и операторов. Формула начинается со знака «=» (равно) Например,

=A3+11*C7

В ячейке, в которой находится формула, по умолчанию отображается число, являющееся результатом вычислений.

В качестве операндов в формуле могут использоваться числа, адреса ячеек и функции.

Операторы используемые в MS Excel могут быть следующих типов:

а) арифметических операторы:

+ – сложение;

- – вычитание;

* – умножение;

/ – деление;

^– возведение в степень;

% – вычисление процента.

б) операторы сравнения (используются для сравнения двух значений):

= – равно;

> – больше;

< – меньше;

> = – больше или равно;

< = – меньше или равно;

< > – не равно.

в) текстовый оператор конкатенации: & – объединение последовательности символов в одну последовательность.

г) операторы ссылки:

; – (точка с запятой) – оператор объединения нескольких адресов;

: – (двоеточие) – ставится между первым и последним адресом диапазона.

При вычислении операции выполняются слева направо при соблюдении трех следующих приоритетов:

– возведение в степень;

– умножение и деление;

– сложение и вычитание.

Одним из операндов формулы может быть встраиваемая в ЭТ функция, которая является заранее определенной фор­мулой и ее значение зависит от аргументов. Аргументы функции, как правило, указываются в скобках, несколько аргу­ментов отделяются один от другого точкой с запятой, например, =СУММ(А2;В4;Е8). Для указания нескольких аргументов, следующих друг за другом, применяют двоеточие, например, =ПРОИЗВЕД(A1:E1). Кроме того, в электронных таб­лицах существуют и безаргументные функции, например, =ТДАТА(); =ПИ(). В качестве аргументов функции могут использоваться числа, адреса ячеек и функции, например:

=СРЗНАЧ(10; 20; 30);

=LOG(B4);

=ЕСЛИ(С1>10; 5; ЕСЛИ(С1>=5; 2; 0)).

Электронная таблица MS Excel имеет в своем составе около 400 различных встроенных функций. Все функции электронной таблицы разделены на следующие категории:

– математические;

– статистические;

– финансовые;

– дата и время;

– логические;

– текстовые;

– ссылки и массивы и др.

Для ввода функций предусмотрен Мастер функций, который вызывается следующими способами:

1) нажатием кнопки Вставка функции на панели инструментов;

2) через команду меню [Вставка Функция ...].

При этом появится окно, показанное на рис. 3.4.

В

Рис. 3.4. Вид окна «Мастер функций»

поле Категория выбирается категория функций, а в правом поле Функция отображается список функций, входящих в данную категорию. Выбрав нужную функцию и указав ее аргументы на следующем шаге, получим значение функции.

Тут вы можете оставить комментарий к выбранному абзацу или сообщить об ошибке.

Оставленные комментарии видны всем.