Добавил:
Upload Опубликованный материал нарушает ваши авторские права? Сообщите нам.
Вуз: Предмет: Файл:
metod2.docx
Скачиваний:
20
Добавлен:
02.03.2016
Размер:
10.16 Mб
Скачать

Задача 2 Транспортная задача

Поставщики товара – оптовые коммерческие предприятия А1 , А2 , А3 имеюттоваров соответственно в количестве а1 , а2 , а3 . Розничные торговые предприятияВ1, В2 , В3 , В4 , В5 – подали заявку на закупку товаров в объемах соответственно: b 1 ,b 2, b 3 , b 4 , b 5 . Тарифы перевозок единицы груза с каждого из пунктов поставки всоответствующие пункты потребления заданы в виде матрицы D и указаны втаблице (матрица тарифов):

Мощности поставщиков

Мощности потребителей

B 1

B 2

B 3

B 4

B 5

A 1

d 11=14

d 12=11

d 13=9

d 14=13

d 15=18

A 2

d 21=6

d 22=5

d 23=14

d 24=4

d 25=14

A 3

d 31=7

d 32=19

d 33=11

d 34=6

d 35=13

а1=250, а2=180, а3=270,

b1=160,b2=120, b3=100,b4=150, b5=170

Найдите такой план перевозки груза от поставщиков к потребителям, чтобы

совокупные затраты на перевозку были минимальными.

Решение:

Для решения этой задачи с помощью средства поиска решений введем данные, как показано на рис. 1.

В ячейки В2:F4 введены стоимости перевозок. Ячейки B6:F8 отведены под значения неизвестных (объемы перевозок). В ячейкиH6:H8 введена потребность в продукции в пунктах распределения. В ячейку G9 введена целевая функция =СУММПРОИЗВ(В2:F4;B6:F8).

Рис.1 Исходные данные к транспортной задаче

В ячейки В9:F9 введены формулы:

=СУММ(B6:B8)

=СУММ(C6:C8)

=СУММ(D6:D8)

=СУММ(E6:E8)

=СУММ(F6:F8),определяющие объем продукции, ввозимой в центры распределения.

В ячейки G6:G8 ведены формулы:

=СУММ(B6:F6)

=СУММ(B7:F7)

=СУММ(B8:F8), вычисляющие объем продукции, вывозимой от поставщика.

Теперь выберем команду «Данные», «Поиск решения» и заполним открывшееся диалоговое окно «Параметры поиска решения», показано на рис. 2.

В диалоговом окне «Параметры поиска решения» установили метод решения «Поиск решения линейных задач». После нажатия кнопки «Найти решение» средство поиска решений находит оптимальный план поставок продукции и соответствующие ему транспортные расходы (рис. 3).

Рис.2 Диалоговое окно Параметры поиска решений

Рис.3 Результат найденного решения

Рис.4. Отчет по результатам

Вывод:Минимальными являются затраты на перевозку грузов от поставщиков к покупателям в сумме 6270 рублей, при этом оптимальным планом перевозки является:

  1. 250 единиц товара а1 для предприятий -покупателей по 120 и 100 единиц для предприятий В2 и В3 и по 30 единиц для предприятия В5;

  2. 180 единиц товара а2 для предприятий -покупателей для предприятий В1 – 30 единиц, В4-150 единиц;

  3. 270 единиц товара а3для предприятий -покупателей по для предприятий В1 – 130 единиц, В5- 140единиц.

Задача 3 Формирование оптимального штата компании

В распоряжении некоторой компании имеется 5 видов должностей: продавцов,кассиров, менеджеров, бухгалтеров, коммерсантов, и 5 кандидатов для ихвыполнения. Претенденты проходили тестирование на профессиональнуюпригодность. Из прошлого опыта известно, что эффективность работы кандидатов вразличных видах работах неодинакова. Коммерческий директор компании произвелоценку деятельности каждого кандидата в каждом виде работ.

Кандидатов

Эффективность работы кандидатов по видам работ

I

II

III

IV

V

1

25

27

64

53

42

2

53

36

56

42

67

3

69

70

56

48

64

4

72

68

45

56

53

5

75

68

73

57

64

Переносим данные задачи в EXCEL. Результаты заполнения таблицы EXCEL можно увидеть на рис.1:

Рис.1Исходные данные

В ячейках B4:F8 введены результаты тестирования претендентов.Ячейки B11:F15 являются изменяемыми ячейками для нашей процедуры.В ячейках B16:F16 находятся суммы значений соответствующих столбцов изменяемых ячеек. Так в ячейке B16 находится сумма ячеек B11:B15. Аналогично в ячейках:

  • в С16 находится сумма ячеек С11:С15;

  • в D16 находится сумма ячеек D11:D15;

  • в E16 находится сумма ячеек E11:E15;

  • в F16 находится сумма ячеек F11:F15.

В ячейках G11:G15 находятся суммы значений соответствующих строк изменяемых ячеек. Так в ячейке G11 находится сумма ячеек B11:F11. Аналогично в ячейках:

  • в G12 находится сумма ячеек B12:F12;

  • в G13 находится сумма ячеек B13:F13;

  • в G14 находится сумма ячеек B14:F14;

  • в G15находится сумма ячеек B15:F15;

Целевая функция заносится в ячейку I4 и вычисляется по формуле «СУММПРОИЗВ(B4:F8;B11:F15)».

Заполнение окна процедуры «Поиск решения»:

-целевая функция: I4;

-значение целевой функции: max;

-изменяемые ячейки:B11:F15;

-ограничения задачи:

B16:F16 =1 иG11:G15 = 1(все свободные рабочие места должны быть заняты);

B4:F80 (изменяемые ячейки должны иметь положительные значения).

В окне «Параметры» установить «Линейная модель», что соответствует решению задачи симплекс-методом. Результаты заполнения окна показаны на рис.2:

Рис.2Диалоговое окно Параметры поиска решений

Выполнив процедуру «Поиск решения» мы получили в первоначальной таблице следующие результаты:

Рис3.Получение первоначальных результатов

Рис.4.Отчет по результатам расчета

Тут вы можете оставить комментарий к выбранному абзацу или сообщить об ошибке.

Оставленные комментарии видны всем.

Соседние файлы в предмете [НЕСОРТИРОВАННОЕ]