Добавил:
Upload Опубликованный материал нарушает ваши авторские права? Сообщите нам.
Вуз: Предмет: Файл:
Информатика Решение задач MS Excel.doc
Скачиваний:
3
Добавлен:
04.12.2018
Размер:
1.62 Mб
Скачать

4.4. Технология выполнения работы

Проектирование рабочего листа включает: ввод исходных данных, конструирование таблицы, создание и форматирование диаграммы с графиком функции.

Ввод исходных данных

Для ввода исходных данных необходимо выполнить следующие действия.

  1. В ячейку D1 ввести текст Лабораторная работа № 3.

  2. В ячейку C2 ввести текст Табулирование функции одной переменной y =.

  3. На ячейке J2 создать объект-формулу, представляющий собой выражение для заданной функции. Объект-формула создаётся с помощью редактора (Мастера) функций Microsoft Equation 3.0.

  4. В ячейку E4 ввести текст Исходные данные.

  5. В ячейку D5 ввести текст Начальная граница отрезка a=.

  6. В ячейку D6 ввести текст Конечная граница отрезка b=.

  7. В ячейку D7 ввести текст Количество интервалов n=.

  8. В ячейку D8 ввести текст Шаг табулирования h=.

  9. В ячейку I5 ввести значение (число) левой границы отрезка.

  10. В ячейку I6 ввести значение (число) правой границы отрезка.

  11. В ячейку I7 ввести значение (число) количества интервалов (n=20).

  12. В ячейку I8 ввести формулу =(I6-I5)/I7. Запись адресов ячеек (ссылок) в формуле осуществляется щелчком мыши по соответствующей ячейке.

Конструирование таблицы и построение графика

Для конструирования таблицы можно выполнить следующие действия.

  1. В ячейку B9 ввести текст Результаты вычислений.

  2. В ячейку B10 ввести текст № п/п.

  3. В ячейку C10 ввести x.

  4. В ячейку D10 ввести y.

  5. В ячейку E10 ввести слово экстремумы.

  6. В ячейку B11 ввести формулу =СТРОКА()-10.

  7. В ячейку C11 ввести формулу =I5+(B11-1)*I8. Ссылки на ячейки I5 и I8 записать в абсолютной форме (=$I$5+(B11-1)*$I$8). Для этого установить указатель мыши в строку формул непосредственно перед ссылкой на ячейку I5 и нажать функциональную клавишу F4, а затем аналогичную операцию выполнить для ячейки I8.

  8. В ячейку D11 ввести формулу для табулирования функции. Например, =ЕСЛИ(C11=0;1;ЕСЛИ(C11>-1; LN(1+C11)/SIN(C11); ”Не сущ.”)).

  9. В ячейку E11 ввести формулу для поиска максимального и минимального из найденных значений функции. Эта формула имеет вид: =ЕСЛИ(D11=МАКС($D$11:$D$31);”<=макс.”; ЕСЛИ(D11=МИН($D$11:$D$31);”<=мин.”;””)).

  10. Заполнение ячеек в столбцах A, B, C, D выполнить с помощью маркера заполнения (так же, как в лабораторной работе № 2).

  11. Построение графика функции осуществить с помощью Мастера диаграмм.

Форматирование рабочего листа

Рабочий лист с полученными результатами можно отформатировать с помощью кнопок панели инструментов Форматирование (нижняя строка кнопок панелей инструментов). Для форматирования рабочего листа можно выполнить следующие действия.

  1. Отформатировать первую строку. Для этого, выделив текст, установить тип шрифта Times New Roman, размер символов 16, начертание текста Полужирный и, при необходимости, расположить его по центру строки относительно содержимого на листе.

  2. Отформатировать вторую строку. Для этого, выделив текст, установить тип шрифта Times New Roman, размер символов 14, начертание текста Полужирный и, при необходимости, расположить его по центру строки относительно содержимого на листе.

  3. Убрать рамку по периметру объекта-функции, отформатировать и переместить его таким образом, чтобы он сочетался с названием работы.

  4. Отформатировать третью строку. Для этого, выделив текст, установить тип шрифта Times New Roman, размер символов 12, начертание текста Полужирный.

  5. Отформатировать 4-7 строки. Для этого, выделив текст, установить тип шрифта Times New Roman, размер символов 10, а тексты a=, b=, n=, h= прижать к правой границе ячеек, выровняв их по вертикали. Содержимое ячеек I5, I6, I7, I8 выровнять по левому краю ячеек.

  6. Расположить название таблицы по середине строки относительно левой и правой границ таблицы.

  7. Выделив строку с названиями столбцов таблицы B10:E10, расположить содержимое ячеек по центру и установить начертание текста Полужирный.

  8. Выделив диапазон ячеек B10:E31, оформить рамку таблицы.

  9. Выделив диапазон ячеек B11:D31, числа расположить по центру, а в интервале E11:E31 содержимое выровнять по левому краю.

  10. Отформатировать диаграмму, если это не было сделано при её создании.

  11. Скопировать объект-формулу в область диаграммы (в строку названия диаграммы) и отформатировать её.