- •Интернет. Сервисы, предоставляемые Интернет.
- •Адресация в Интернет. Классы и структура ip-адресов. Выделенные ip-адреса.
- •2.3 Механизм динамического выделения адресов.
- •Маска ip -подсети. Разделение ip -сети на подсети.
- •Доменная система имен в Интернет. Регистрация доменного имени.
- •Электронная почта и ее возможности. Формат электронного письма. "Мусорная" почта (спама): способы ее сокращения.
- •Подключение к Интернет.
- •Поиск информации в Интернет. Популярные поисковые системы. Составление поискового запроса.
- •Организация рекламы в Интернет. Этапы создания web -сайта.
- •Назначение и основные конструкции языка html. Структура html документа
- •Структура html-файла
- •Основы cgi. Назначение и схема работы.
- •Основы Cookies. Назначение и схема работы
- •Proxy -сервер: назначение и использование.
- •Dhcp -сервер: назначение и использование.
-
Электронная почта и ее возможности. Формат электронного письма. "Мусорная" почта (спама): способы ее сокращения.
Электронное письмо состоит из следующих основных элементов:
-
Заголовок письма;
-
Характеристика письма;
-
Текст письма.
Первые два элемента письма образуют "конверт с адресом". Информация конверта используется различными компьютерными системами и поэтому для правильной ее обработки применяют международный формат электронных сообщений, который определен документом "Standart for the Format of ARPA - Internet Text messages" или RFC822 (Request for Comment), его также называют форматом Internet.
В соответствии с описанием этого формата строки в начале письма содержат описание маршрута движения сообщения по цепочке хост-машин и содержат сведения о местоположении (IP-адрес) компьютера провайдера (хост-машины) в сети, используемом программном обеспечении, времени получения входящего и времени отправления исходящего письма и другую информацию.
Заголовок письма формируется автоматически с учетом тех адресов, которые запишет отправитель в процессе подготовки сообщения.
Вторая часть письма содержит характеристики самого письма. Они также генерируются автоматически в процессе отправки письма.
Третья часть письма представляет собой непосредственно текст сообщения (текстовый или закодированный бинарный файл).
Служба электронная почта - предназначена для обмена сообщениями (письмами).
Клиент (MS Outlook, The bat ...) готовит ("упаковывает") и посылает серверу (почтовое отделение) сообщения, принимает и просматривает сообщения.
Сервер электронной почты (Sendmail, MS Exchange ...) обрабатывает сообщения (сортирует) и отправляет локальному адресату или удаленному серверу (почтовому отделению).
Электронная почта во многом похожа на обычную почтовую службу.
Формат сообщения.
Первый стандарт - RFC0724 (Proposed official standard for the format of ARPA Network messages D. Crocker, K.T. Pogran, J. Vittal, D.A. Henderson May-12-1977).
Последняя версия - RFC2822 (Internet Message Format P. Resnick, Ed. April 2001).
Текстовая (ASCII) информация может передаваться, как есть.
Остальная информация должна быть закодирована, т.к. изначально не предполагалось ее передавать. При использовании расширения протокола SMTP - ESMTP (Enhaced SMTP) можно кодировать в 8-битном виде. Это все выполняет почтовая программа.
Виды кодирования:
base64 - кодирует из набор 00-FFв ASCII, чтобы можно было передавать по SMTP (кодируют бинарные файлы).
7bit - не кодирует, указывает, что код ASCII.
8bit - указывает, что не только символы ASCII.
quoted-printable - используется для кодирования национальных языков, символов второй части таблицы ("А" - "=3D").
Сообщение состоит из:
-
конверта сообщения (информация для доставки и обработки сообщения)
-
тела сообщения (данные отправителя)
Некоторые поля заголовка:
From - адреса отправителей.
Sender - адрес реального отправителя.
Пример:
From: vasy@mail.ru
pety@mail.ru
Sender: misha@mail.ru
To - адрес получателя.
Cc - адреса получателей копий сообщений.
Пример:
To: vasy@mail.ru
pety@mail.ru
Cc: misha@mail.ru, katy@mail.ru
Date - дата отправки сообщения.
Subject - тема сообщения.
Message-ID - уникальный идентификатор сообщения.
Reply-To - адрес для ответа.
Received - адреса и время обработки сообщения промежуточным сервером.
X-Mailer - тип и версия почтовой программы клиента.
Comments - комментарии.
Priority - приоритетность.
Organization - название организации отправителя
Защита от спама с помощью брандмауэров
брандмауэр - это не просто маршрутизатор, хост или группа систем, которые обеспечивают безопасность в сети. Брандмауэр - это подход к безопасности; он помогает реализовать политику безопасности, которая определяет разрешенные службы и типы доступа к ним, и является реализацией этой политики в терминах сетевой конфигурации, нескольких хостов и маршрутизаторов, и других мер защиты. Основная цель системы брандмауэра - управление доступом К или ИЗ защищаемой сети. Он реализует политику сетевого доступа, заставляя проходить все соединения с сетью через брандмауэр, где они могут быть проанализированы и разрешены либо отвергнуты.
Microsoft выпустила общественную версию Windows Vista Beta 2, небольшое сообщество Beta-тестеров расширилось. В Windows Vista Beta 2 появились новые особенности. Одна из наиболее ожидаемых возможностей, включенных в общественную Beta 2 - новый брандмауэр Windows, который является всесторонним средством межсетевой защиты, обеспечивающим контроль, как за входящим, так и за исходящим трафиком. По сравнению с брандмауэром Windows XP, который обеспечивал лишь контроль над входящим трафиком, брандмауэр Windows Vista является большим шагом вперед в области безопасности.
Центр нового брандмауэра сосредоточен в консоли Windows Firewall with Advanced Settings, с помощью этой консоли можно проверить производительность брандмауэра, так же можно задать, изменить или удалить правила, а администраторы могут установить объем информации, которая может быть записана и где именно она может быть записана. Определенные области (касающиеся входящего или исходящего трафика или того и другого) детально показывают все установленные правила, позволяя изменить любое правило или создать новое. Кроме того, каждое правило имеет свои свойства, где почти любое значение может быть изменено.
Защита от спама с помощью фильтров
Защитить компьютер от мусорной почты можно с помощью настроек сетевого фильтра.
