- •Российская открытая академия транспорта Инфокоммуникационные системы и сети
- •Глава 1. Введение в сетевые технологии
- •1.1. Эволюция вычислительных систем
- •1.2. Назначение компьютерной сети
- •1.3. Конфигурация сети
- •1.4. Топология сети
- •1.4.1. Базовые топологии
- •1.4.2. Выбор топологии
- •Глава 2. Физическая среда передачи нформации
- •2.2. Передача дискретных данных на физическом уровне
- •2.3 Методы доступа
- •Глава 3. Сетевые стандарты
- •3.1. Модель osi
- •3.1.1 Уровни модели osi
- •3.1.2. Взаимодействие уровней модели osi
- •3.1.3. Другие сетевые модели
- •3.2. Стандарты Project ieee 802.X
- •Глава 4. Набор протоколов tcp/ip
- •4.1. Описание наиболее распространенных протоколов tcp/ip
- •4.1.1. Межсетевой протокол последовательной линии slip
- •4.1.2. Протокол соединения “точка-точка” ppp
- •4.1.3. Межсетевой протокол ip
- •4.1.4. Протокол управляющих сообщений Internet
- •4.1.5. Протокол преобразования адресов arp
- •4.1.6. Обратный протокол arp
- •2.1.7. Протокол udp
- •2.1.8. Протокол tcp
- •2.1.9. Протокол dhcp
- •4.2. Схема ip адресации
- •4.2.1. Классы и структура ip-адресов
- •4.2.2. Маски подсетей
- •4.2.3. Широковещательные домены и шлюзы по умолчанию
- •4.3 Другие способы адресации, используемые в протоколах tcp/ip
- •4.3.1. Бесклассовая междоменная маршрутизация
- •4.3.2. Адресация уровня 4
- •4.3.3. Трансляция сетевых адресов и адресация в закрытой сети
- •4.3.4. Маршрутизация
- •5. Проектирование лвс
- •Литература
Глава 4. Набор протоколов tcp/ip
Набор протоколов TCP/IP был разработан в начале 70-х годов прошлого столетия для сети ARPANET Министерства обороны США, на основе которой была создана сеть Internet. В настоящее время это один из немногих наборов протоколов, который полностью не зависит от какой-либо одной коммерческой организации и поддерживается практически всеми операционными системами. Все протоколы, входящие в набор TCP/IP, описаны в документах, известных под названием запросов на комментарии (RFC – Request for Comment), и доступны на Web-узле http://www.rfc-editor.org/.
4.1. Описание наиболее распространенных протоколов tcp/ip
4.1.1. Межсетевой протокол последовательной линии slip
Межсетевой протокол последовательной линии (Serial Line Internet Protocol – SLIP) определяет способ инкапсуляции данных, передаваемых по последовательным соединениям. Протокол SLIP фактически считается стандартом, который очень напоминает протокол канального уровня. Он предназначен для инкапсуляции пакетов протоколов верхнего уровня и дальнейшей их передачи по последовательным соединениям (т.е. соединениям, образованным с помощью модемов). Протокол SLIP не поддерживает целый ряд средств, таких как сжатие, обнаружение ошибок, динамическую адресацию или поле типа, позволяющее обозначить применяемый протокол уровня 3. Протокол SLIP все еще поддерживается целым рядом операционных систем, но в основном заменен более надежным (и сложным) протоколом РРР.
Протокол SLIP определен в документе RFC 1055 (стандарт 47), который находится по адресу ftp://ftp.isi.edu/in-notes/std/std47.txt.
4.1.2. Протокол соединения “точка-точка” ppp
Протокол соединения “точка-точка” (Point to Point Protocol – РРР) представляет собой еще один протокол инкапсуляции данных, который может применяться в линиях передачи многих типов. Это очень надежный и легко настраиваемый протокол. В настоящее время он является основным стандартом последовательной связи с использованием модемов и включает в себя набор следующих протоколов:
Протокол управления каналом (Link Control Protocol – LCP), который применяется для согласования опций инкапсуляции, обнаружения ошибок в конфигурации, аутентификации другого участника соединения и для разрыва соединений;
Протокол аутентификации по паролю (Password Authentication Protocol – PAP), который обеспечивает аутентификацию пользователей в последовательных линиях. Аутентификация осуществляется открытым текстом без шифрования;
Протокол аутентификации с предварительным согласованием вызова (Challenge Handshake Authentication Protocol – CHAP), который также используется для аутентификации пользователей в последовательных линиях, однако в отличии от PAP, аутентификация проводится с шифрованием;
Семейство протоколов управления сетью (Network Control Protocols – NCPs), которое предназначено для установления и конфигурирования протоколов сетевого уровня.
Протокол РРР поддерживает следующие средства:
сжатие заголовков IP (RFC 2509);
сжатие данных с применением целого ряда алгоритмов, включая MPPC (Microsoft Point-to-Point Compression – сжатие данных в соединении “точка-точка” по алгоритму Microsoft), Predictor и STAG;
поддержка многих протоколов верхнего уровня с использованием разных протоколов NCP;
мультиплексирование пакетов нескольких протоколов верхнего уровня, передаваемых по одному физическому соединению, допустим, предоставление возможности передавать по одному коммутируемому соединению одновременно пакеты TCP/IP и пакеты IPX/SPX;
динамическое распределение адресов (с помощью соответствующего протокола NCP);
обнаружение ошибок с использованием контрольной последовательности фрейма;
туннелирование с использованием протокола туннелирования уровня 2 (L2 Tunneling Protocol – L2TP) (RFC 2661) или протокола туннелирования в соединении “точка-точка” (Point-to-Point Tunneling Protocol – РРТР) (RFC 2637);
поддержка целого ряда технологий физического и канального уровней, включая Х.25, последовательную передачу, Frame Relay и асинхронный режим передачи (ATM) с использованием уровня адаптации AAL5;
группирование соединений с помощью многоканального протокола (МР) (RFC 1990);
динамическое распределение пропускной способности с использованием протокола ВАР (RFC 2125).
Протокол РРР формально определен документами RFC 1661 и 1662 (стандарт 51), которые находятся по адресу ftp://ftp.isi.edu/in-notes/std/std51.txt.
