Добавил:
Опубликованный материал нарушает ваши авторские права? Сообщите нам.
Вуз: Предмет: Файл:
Курсовой проект и индивидуальные задания / Отчёт по курсовому (общему) проекту.docx
Скачиваний:
0
Добавлен:
30.09.2026
Размер:
767 Кб
Скачать
☆
  1. Контрольный пример

RFC 2544

Подходит для тестирования отдельно взятого интерфейса

Throughput

Определяет пропускную способность тестируемого устройства по рекомендации RFC 1242.

Определяет нагрузки, при которых нет потерь пакетов.

Latency

Измеряет задержку по кадрам выборочно, по рекомендации RFC1242.

Frame Loss

Определяет частоту потери кадров, по рекомендации RFC1242, во всем диапазоне скоростей данных и размеров кадра.

Определяет зависимость потерь от нагрузки.

Jitter

Абсолютная разность задержек распространения двух последовательно принятых пакетов, принадлежащих одному потоку данных.

Back-To-Back

Определяет возможность устройства по обработке кадров back-to-back, по рекомендации RFC1242.

ITU-T 1564

Ориентировка на SLA, многопоточность, соответствие MEF.

Тест на конфигурацию предназначен для измерения способности тестируемого устройства или сети правильно передавать данные в различных состояниях:

На этапе CIR измеряются показатели производительности услуги и сравниваются с целями SLA.

На этапе EIR, когда производительность не гарантируется и измеряется скорость передачи услуг, нужно убедиться, что CIR — это минимальная пропускная способность.

В фазе отбрасывания, когда услуга генерируется на скорости превышения и ожидаемая скорость пересылки не превышает установленную скорость передачи информации или скорость превышения (если она настроена).

На этапе CBS (Committed Burst Size) измеряются показатели производительности при изменении трафика с CIR на битрейт.

На этапе EBS (Excess Burst Size) измеряются показатели производительности при изменении трафика с EIR на битрейт.

Метрики: ширина полосы (IR), латенция (FTD), джиттер (FDV), коэффициент потери кадров (FLR), доступность (AVAIL).

RFC 6349

Проверка качества и производительности приложений, требования корпоративных клиентов, MTU, policing/shaping, буфер и размер окна TCP.

Управление конфигурациями

E-LMI, E-DI, XML PPI (IETF Netconf), TR-069, Config Replace and Rollback, MIB Persistance

Производительность

IP SLA (задержка, джиттер, потеря пакетов), CBQoS MIB, NBAR, RMON, ERM.

Безопасность (Security)

AAA, AutoSecure, LDP Auth, Routing Auth

Embedded Resource Manager

Мониторинг системных ресурсов (CPU, RAM, Buffers).

Файлы конфигурации

Журналировать вводимые команды, извещать о факте изменения конфигурации, разграничение прав доступа.

В случае, когда изменения приводят к потере доступности, нужно rollback на заранее указанную конфигурацию через 2 минуты, если изменения не подтверждены.

Архивирование конфигурации на сервер TFTP, использование KRON в качестве планировщика, либо использовать EEM с Timer Event Detection.

Мониторинг доступности сервиса

Слежение за доступностью с помощью Enhanced Object Tracking (EOT) и Embedded Event Manager (EEM).

GOLD диагностика и оптимизация

Bootup-диагностики, periodic health мониторинг, on demand (CLI), scheduled testing (CLI).

Прикладное тестирование

Произвести настройку сетевой инфраструктуры.

Согласно политике доступа поместить на File Server файл, а затем убедиться в успешном результате.

Для проверки НСД необходимо сохранить проверяемую конфигурацию сетевых устройств, затем вновь «развернуть» её на устройствах и провести повторные тесты доступа/отказа в доступе.