Добавил:
Опубликованный материал нарушает ваши авторские права? Сообщите нам.
Вуз: Предмет: Файл:

Курсовой проект и индивидуальные задания / Отчёт по курсовой работе (индивидуалка, 16 вариант)

.docx
Скачиваний:
0
Добавлен:
30.09.2026
Размер:
31 Кб
Скачать
☆

МИНИСТЕРСТВО ЦИФРОВОГО РАЗВИТИЯ, СВЯЗИ И МАССОВЫХ КОММУНИКАЦИЙ РОССИЙСКОЙ ФЕДЕРАЦИИ

Ордена Трудового Красного Знамени

федеральное государственное бюджетное образовательное учреждение

высшего образования

«Московский технический университет связи и информатики»

(МТУСИ)

Кафедра Сетевые информационные технологии и сервисы Shape1

(название полностью)

КУРСОВАЯ РАБОТА

по дисциплине

«Управление и администрирование информационных систем»

по теме

«Требования к реализации сетевых протоколов в Telegram»

Выполнил:

Нарожный Александр Ильич

Проверила:

Беленькая Марина Наумовна

Москва 2025

Содержание

1. Требования к реализации сетевых протоколов в Telegram 3

2. Требования по уровням модели OSI: 3

Список используемых источников 7

  1. Требования к реализации сетевых протоколов в Telegram

Протокол — набор правил, определяющих взаимодействие компонентов системы.

Стандарт — техническая реализация протокола.

Реализация протоколов в Telegram должна соответствовать международным стандартам и обеспечивать безопасность, производительность и масштабируемость.

  1. Требования по уровням модели OSI

1. Физический уровень

EIA/TIA-568A, 568B - Разводка витой пары.

EIA/TIA-569 - Прокладка КС.

FC (Fibre Channel) — используемая для подключения компьютерных систем хранения данных к серверам. ANSI X3.230

2. Канальный уровень

IEEE 802.3 - Стандарты для передачи данных через различные среды.

PPP (Point-To-Point Protocol) - протокол прямого соединения между узлами. RFC 1661.

LCP (Link Control Protocol) - часть PPP для установки, настройки и тестирования соединения. RFC 1661

HDLC (High-Level Data Link Control) - стандарт управления каналом. ISO 13239

FC (Fibre Channel) — используемая для подключения компьютерных систем хранения данных к серверам. ANSI X3.230

Ethernet - Стандарт проводной передачи данных (IEEE 802.3)

3. Сетевой уровень

IP (Internet Protocol) - Обеспечивает логическую адресацию и маршрутизацию пакетов между сетями ICMP. RFC 791

ICMP (Internet Congestion Management and Routing) - используется для диагностики проблем в сети, передачи сообщений об ошибках и управлении сетью RFC 792

OSPF (Open Shortest Path First) - Протокол динамической маршрутизации, использующий алгоритм Дейкстры для определения кратчайших маршрутов. RFC 2328

ARP (Address Resolution Protocol) - Преобразует логические IP-адреса в физические MAC-адреса. RFC 826

FC (Fibre Channel) — используемая для подключения компьютерных систем хранения данных к серверам. ANSI X3.230

4. Транспортный уровень

TCP (Transmission Control Protocol) - управление передачей данных.

RFC 793

UDP (User Datagram Protocol) - доставка дейтаграмм без подтверждения. RFC 768

RTCP (Real-time Transport Control Protocol) - Используется для управления и мониторинга потоков RTP, предоставляя информацию о качестве передачи. RFC 3550

RTP (Real-time Transport Protocol) - Обеспечивает передачу данных в режиме реального времени, таких как аудио и видео. RFC 3550

FC (Fibre Channel) — используемая для подключения компьютерных систем хранения данных к серверам. ANSI X3.230

5. Сеансовый уровень

MTProto 2.0 - Протокол передачи данных, разработанный для Telegram (SHA-256, RSA-2048, AES-256, Diffie-Hellman).

RPC (Remote Procedure Call) - вызов функций в удаленных адресных пространствах. RFC 5531

SMB (Server Message Block) - обеспечивая установку и управление сеансами между клиентами и серверами. RFC 1002

FC (Fibre Channel) — используемая для подключения компьютерных систем хранения данных к серверам. ANSI X3.230

6. Уровень представления

ISO 8823 - Процедуры передачи данных между логическими объектами уровня представления.

XDR (External Data Representation) - Стандарт для представления данных, используется для преобразования форматов данных между разными системами. RFC 450

RDP (Remote Desktop Protocol) - Обеспечивает доступ к рабочему столу. ITU (T.120, T.125, T.128)

MPEG (Moving Picture Experts Group) - Для сжатия видео и аудио, который используется для передачи мультимедийных данных в виде потоков. ISO/IEC 11172, ISO/IEC 14496, ISO/IEC 23009

7. Прикладной уровень

FIPS 140-2 / 140-3 - Стандарты безопасности криптографических модулей

SHA (FIPS 180-4) - Алгоритмы хеширования. SHA-256

ANSI - Использование симметричных ключей в дискретной логарифмической криптографии. X9.42

NTS (Network Time Security) - Обеспечивает безопасную синхронизацию времени в сетях. RFC 8915

NTFS (New Technology File System) – Файловая система.

Список используемых источников

  1. Беленькая М. Н., Малиновский С. Т., Яковенко Н. В Администрирование в информационных системах. Учебное пособие для вузов. – М.: Горячая линия – Телеком, 2011. – 400 с

  2. В. Олифер Н. Олифер Компьютерные сети. Принципы, технологии, протоколы. - СПб.: Питер, 2020. — 944 с

  3. Обзор основных протоколов доставки для виртуальных рабочих мест [Электронный ресурс], URL: https://market.cnews.ru/articles/2024-08-11_kratkij_obzor_protokolov_dostavki (дата обращения: 09.04.2025).

2