- •«Московский технический университет связи и информатики»
- •Содержание
- •Основная информация о Ozon
- •Стандарты и протоколы
- •Системное мат. Обеспечение
- •1. Рекомендации.
- •Алгоритм ближайших соседей работает следующим образом:
- •Влияние системы рекомендаций Ozon
- •Влияние системы фильтрации Ozon
- •3. Прогнозирование спроса.
- •2. Фильтрация.
- •Развитие системы прогнозирования спроса Ozon
- •4. Ценовая оптимизация.
- •5. Анализ данных.
- •Развитие системы анализа данных Ozon
- •Фронтенд
- •Бэкенд Система управления базами данных
- •Технологии
- •Сервисы
- •Инструментарий сервисов
- •Инструменты создания программно-аппаратной части сервиса на примере ozon Travel
- •Центры обработки данных
- •Кабельная и сетевая часть
- •Подсистемы кабельной системы здания и кампуса.
- •Подсистема скс (Структурированная кабельная система) Ozon
- •Управление и системы диагностики
- •Кабельные тестеры и анализаторы на разных уровнях osi
МИНИСТЕРСТВО ЦИФРОВОГО РАЗВИТИЯ, СВЯЗИ И МАССОВЫХ КОММУНИКАЦИЙ РОССИЙСКОЙ ФЕДЕРАЦИИ
Ордена Трудового Красного Знамени федеральное государственное бюджетное образовательное учреждение высшего образования
«Московский технический университет связи и информатики»
Кафедра «Сетевые информационные технологии и сервисы»
Дисциплина «Архитектура информационных систем»
ОТЧЁТ
По проектной работе
По теме «Архитектура Ozon»
Выполнили:
студенты группы БСТ2104
Проверила: Беленькая М.Н.
Москва, 2023 г.
Содержание
Основная информация о Ozon 3
Стандарты и протоколы 5
Системное мат. обеспечение 11
Модули 21
Фронтенд 27
Бэкенд 28
Центры обработки данных 34
Кабельная и сетевая часть 41
Основная информация о Ozon
Ozon — это одна из крупнейших российских интернет-торговых площадок, предоставляющая широкий ассортимент товаров и услуг для миллионов пользователей.
Основание и история:
Ozon был основан в 1998 году. С течением времени компания стала одним из ведущих игроков на рынке электронной коммерции в России.
Основные виды продуктов и услуг:
Платформа предлагает широкий ассортимент товаров, включая товары для дома, электронику, книги, одежду, косметику, продукты питания и многое другое. Озон также предоставляет услуги доставки и сервисы по поддержке клиентов.
Технологические решения:
Ozon активно инвестирует в технологии и разработку. Компания использует современные технологии для обеспечения удобства пользователей, эффективной логистики и стабильной работы платформы.
Инновации и развитие:
Ozon стремится быть в центре инноваций в сфере электронной коммерции. Компания внедряет новые технологии, улучшает пользовательский опыт и расширяет свой бизнес.
Торговая модель:
Ozon использует гибкую торговую модель, объединяя как собственные склады, так и сотрудничество с множеством поставщиков. Это позволяет предоставлять большой выбор продукции.
Логистика и доставка:
Компания активно работает над совершенствованием логистических решений и услуг по доставке, включая ускоренные и удобные варианты.
Капитализация и финансовое положение:
Ozon является публичной компанией, капитализация которой может меняться в зависимости от рыночных условий. Важным фактором успешного развития компании является ее финансовая стабильность.
Стандарты и протоколы
Информационная система Ozon основана на эталонной модели взаимодействия открытых систем ЭМВОС, созданной Международной организацией по стандартизации (ISO) в 1977 году. Эта модель определяет уровни взаимодействия в компьютерных сетях, описывая функции каждого уровня, но не стандартизирует их выполнение.
Протоколы - способы и правила, при помощи которых осуществляются обмен данных между компьютерами.
Стандарт - это вариант реализации протокола в аппаратуре или программном обеспечении.
Модель OSI определена в стандарте ISO/IEC 7498 и состоит из следующих частей:
ISO/IEC 7498-1 Базовая модель
Архитектура безопасности ISO/IEC 7498-2
ISO/IEC 7498-3 Именование и адресация
ISO/IEC 7498-4 Структура управления
ISO/IEC 7498-1 также опубликован как Рекомендация ITU-T X.200.
Таблица 1 – Уровни модели OSI
Уровень |
Функции |
PDU |
7. Прикладной |
Взаимодействие приложений между собой |
Сообщения |
6.Представительский |
Представление данных между сетевым сервисом и приложением |
Сообщения |
5. Сеансовый |
Управление сеансами, длительный обмен информацией. |
Сообщения |
4. Транспортный |
Надежная передача сегментов между двумя нодами в сети |
Сегменты |
3. Сетевой |
Структуризация, управление, множество нод |
Датаграммы |
2. Канальный |
Надежная передача датафреймов между двумя нодами соединенных физическим уровнем |
Фреймы |
1. Физический |
Передачи потока данных через физическое устройство, согласование среды передач, адреса |
Биты |
Разбиение на уровни для Ozon представлено в таблицах 2-8. Также там приведены стандарты и протоколы, использующиеся на каждом из уровней.
Таблицы 2 - 8 – Основные стандарты и протоколы уровней модели OSI для Ozon.
Таблица 2 - Физический уровень
Стандарт |
Протокол |
Сфера использования |
FC-0 |
Fibre Channel |
передача данных и обеспечения надежности |
10BASE-T, 100BASE-T, 10GBASE-T |
Ethernet |
передача данных между устройствами |
TIA-232-F |
RS-232 |
используется в сетевом оборудовании; приём и передача данных по схеме точка-точка |
TIA-942 |
Ethernet |
определяет минимальные требования к структурированной кабельной сети |
TIA-568 |
Ethernet |
определяет кабельную инфраструктуру для телекоммуникационных систем в зданиях коммерческого класса |
Обеспечивает передачу потока бит в физическую среду передачи информации. В основном определяет спецификацию на кабель и разъемы, т.е. механические, электрические и функциональные характеристики сетевой среды и интерфейсов
Таблица 3 - Канальный уровень
Стандарт |
Протокол |
Сфера использования |
IEEE 802.2 |
LLC |
управление логическим каналом, обеспечивает единый интерфейс для |
FC-1 |
Fibre Channel |
передача данных и обеспечения надежности |
IEEE 802.1D |
STP |
предотвращение петель между мостами и избегание широковещательных радиаций |
На этом уровне биты организуются в группы (фреймы, кадры). Кадр - это блок информации, имеющий логический смысл для передачи от одного компьютера другому. Каждый кадр снабжается адресами физических устройств (источника и получателя), между которыми он пересылается
Таблица 4 - Сетевой уровень
Стандарт |
Протокол |
Сфера использования |
FC-2 |
Fibre Channel |
передача данных и обеспечения надежности |
RFC-792 |
ICMP |
используется для передачи сообщений об ошибках и других исключительных ситуациях, возникших при передаче данных |
RFC-791 |
IP |
маршрутизируемый протокол сетевого уровня стека TCP/IP |
Основной задачей этого уровня является передача информации по сложной сети, состоящей из множества островков (сегментов). Внутри сегментов могут использоваться совершенно разные принципы передачи сообщений между конечными узлами - компьютерами. Сеть, состоящую из многих сегментов, мы называем Интернет. Начиная с сетевого уровня, все вышележащие протоколы реализуются программными средствами, обычно включаемыми в состав сетевой операционной системы.
Таблица 5 - Транспортный уровень
Стандарт |
Протокол |
Сфера использования |
RFC 793, STD 7 |
TCP |
передача данных в интернете, надежная передача данных между узлами
|
RFC 768, STD 6 |
UDP |
позволяет приложениям отправлять сообщения другим хостам по IP-сети без необходимости предварительного сообщения для установки специальных каналов передачи или путей данных. |
FC-3 |
Fibre Channel |
передача данных и обеспечения надежности |
Транспортный уровень предназначен для организации необходимой степени надежности передачи данных вне зависимости от физических характеристик использующейся сети или сетей.
Таблица 6 - Сеансовый уровень
Стандарт |
Протокол |
Сфера использования |
RPC |
Fibre Channel |
набор правил и процедур, которые определяют, как клиент и сервер должны обмениваться данными и вызывать удаленные процедуры |
FC-4 |
Fibre Channel |
передача данных и обеспечения надежности |
Уровень позволяет пользователям различных компьютеров устанавливать сеансы связи друг с другом. При этом обеспечивается открытие сеанса, управление диалогом устройств (например, выделение места для файла на диске принимающего устройства) и завершение взаимодействия. Это делается с помощью специальных программных библиотек (пример, RPC-удаленные вызовы процедур от Sun Microsystems).
Таблица 7 - Представительский уровень
Стандарт |
Протокол |
Сфера использования |
ISO/IEC 8802-2 |
LPP |
управление логическим каналом для передачи данных |
ISO/IEC 8802-2 |
XDR |
представление данных в независимой от платформы форме |
ISO 8823 |
X.226, X.227, X.228 |
надежная передача данных в сетях, установление, поддержание и завершение сеансов связи, обработка ошибок |
RFC 5246, RFC 8446 |
TLS |
обеспечивает защищенную передачу данных между узлами в сети Интернет |
Уровень выполняет преобразование данных между компьютерами с различными программируем код для символов, используя ASCII и EBCDIC, то есть выполняет синтаксические различия в представлении данных. На этом уровне может выполняться шифрование и дешифрирование и сжатие данных.
Таблица 8 - Прикладной уровень
Стандарт |
Протокол |
Сфера использования |
ISO 8571 |
FTP |
передача, доступ и управление файлами |
RFC 5321 |
SMTP |
отправка электронной почты в сетях TCP/IP |
RFC 7545 |
HTTP |
передача гипертекста |
RFC 5034
|
POP3 |
получения электронной корреспонденции с удаленного почтового сервера |
На этом уровне происходит взаимодействие между приложениями: определяется модель, по которой будет происходить обмен файлами, устанавливаются правила, по которым мы будем пересылать почту, организовывать виртуальный терминал, сетевое управление, директории.
VLAN
VLAN – технология логической группировки сетевых узлов и ресурсов в виртуальные сети. VLAN позволяют сегментировать единый широковещательный домен на более мелкие. Регулируется стандартом IEEE 802.1q.
